Soporte TLS

¿Por qué solo admitimos TLS 1.2 y superior?

El PCI Security Council establece las reglas sobre qué tecnologías son aceptables para su uso en la transmisión de datos de titulares de tarjetas. Han identificado explícitamente que TLS 1.0 ya no es una forma sólida de cifrado porque es vulnerable a muchos ataques conocidos.

Casi todos los sitios web han dejado de admitir TLS 1.0 y 1.1, esto se hace para ayudar a proteger su información.

¿Estás afectado?

Si no utiliza nuestras API, es poco probable que se vea afectado a menos que esté utilizando un navegador o sistema operativo realmente antiguo. Para verificar si su computadora / navegador es compatible con TLS 1.2 o superior, visite este enlace: https://www.ssllabs.com/ssltest/viewMyClient.html

Soporte de biblioteca api

Si tiene un código que se conecta con la API ZeroBounce, debe asegurarse de que seguirá funcionando después de junio 1, 2018. Cada idioma y biblioteca es diferente, a continuación se encuentran los idiomas más populares.

Estos idiomas necesitarán cambios / actualizaciones importantes para funcionar:

  • Java 6 u45 / 7 u45
  • .NET antes de 4.5 (no es compatible con TLS 1.2)
  • .NET 4.5 (debe haber cambiado la configuración para habilitar explícitamente TLS 1.2)
  • OpenSSL 0.9. 8
  • La mayoría de los lenguajes dinámicos como Ruby, PHP y Python dependen de la versión OpenSSL del sistema operativo subyacente. Puede verificarlo ejecutando la versión OpenSSL. 1.0. 1 en el mínimo requerido.
  • PHP 5.5. 19 y superior tiene soporte para TLS 1.2

Puede probar su conexión con varias herramientas y documentación que se encuentran en Internet. Tenga en cuenta que no somos expertos en todos los idiomas o marcos, por lo que no podemos probar o corregir su código.

Instrucciones específicas del idioma

  • .NET 4.6: TLS 1.2 se usa automáticamente. No hay cambios necesarios.
  • .NET 4.5: SecurityProtocolType debe cambiarse a Tls12 (utilizando el Setter SecurityProtocol)
  • .NET 4.0: TLS 1.2 es compatible, pero no hay una enumeración de SecurityProtocolType con nombre. Utilice (SecurityProtocolType) 3072.
  • .NET 3 y menos: debe actualizarse a 4.5

Compatibilidad con las versiones predeterminadas del sistema TLS incluidas en .NET

Soporte de navegador

La mayoría de los navegadores han admitido TLS 1.2 durante varios años.

Los siguientes navegadores NO HAGA admite TLS 1.2 y ya no funcionará.

  • Google chrome 29
  • Firefox 26
  • Explorador de internet 10
  • Safari 8
  • ios 4
  • Android 4